EBS: Error 500 ‘Sorry, we were not able to process your request’ After Logging in to the Manager Portal

2026-01-06 18:09:28 UTC

Problem

After logging into the Everbridge Suite Manager Portal, users are seeing the following error:

500 - Sorry we were not able to process your request An internal server error occurred. Please refresh the page to try again.

Root Cause

Users are most likely using a bookmark to login to the Everbridge Suite Manager Portal, similar to https://manager.everbridge.net/dashboard. Because this bookmark is linking to a deeper link within the application, an error is shown. The Everbridge Suite Manager Portal does not support the use of deeplinking.

Solution

If you're accessing the Manager Portal:

If you're using the Member Portal:

  • This error occurs when Secure Messaging is enabled but the Mobile Push Alert delivery method isn't enabled. Enable Mobile Push Alert in your delivery methods settings.[2]

General troubleshooting steps:

  • Clear your browser's cache and cookies[3]

  • Refresh the page

  • Try a different browser or incognito mode[4]

  • Ensure you're using a supported, up-to-date browser

Check system status:

Visit our status page at https://evbgcem.statuspage.io/ to see if there are any ongoing incidents affecting the platform.

Reference knowledge articles:

  1. EBS: Error 500 ‘Sorry, we were not able to process your request’ After Logging in to the Manager Portal

  2. EBS: Error 500: 'Sorry, we are experiencing technical difficulties' When Registering or Logging in to the Everbridge Member Portal

  3. EBS: The Manager Portal Page Is Not Loading Correctly in Everbridge Suite

  4. EB360: 'Sorry, you can't access this resource!' Error Using Email Ingestion in Everbridge Suite

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