EBS: Incident Operator Unable to Send Updates on Previously Launched Incidents in Everbridge Suite

Problem

Incident Operators can launch Incidents, but are unable to send updates or otherwise interact with Incidents that were launched by a different role (for example, an Incident Admin). This includes not being able to close those Incidents or add/update recipients on notifications sent from them.

Root Cause

Incident permissions in Everbridge Suite are scoped by role. An Incident Operator can send updates to, or otherwise interact with, only those Incidents that were launched using the same Incident Operator role. They cannot update or close Incidents created by other roles (such as Admin or Incident Admin roles), and custom roles cannot be granted cross-role incident visibility.

Additionally, this behavior is not affected by incident status (for example, scheduled vs. active). The platform does not provide an Edit option for scheduled Incidents, even when using Admin or Incident Operator roles.

Solution

If you want a user to update or close any Incident regardless of which role launched it, they must use an Admin-level role (such as Organization Admin or Account Admin). Admin roles can view and interact with Incidents launched by any role.

If you do not want to grant an Admin role, an operational workaround is for an Admin to send messages/updates on behalf of the team (for example, using a Message Sender role) from the relevant Incident.

Users with the Incident Operator role who also need to manage contact lists or notification recipients must be assigned a role that includes notification and group-management capabilities. Otherwise, the necessary groups or recipients must be maintained by someone with the appropriate administrative or IT permissions.

For more detailed information on roles and permissions, see knowledge article: EBS Everbridge Suite Roles and Permissions.

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