Problem
Template components such as Publishing Options, Incident Chat, etc are deselected after saving template modification in Everbridge Suite.
Root Cause
This can happen when a role that does not have permission to view the deselected components, edits and saves the template. While editing the template, the user was warned that components may be deleted. For more information on the warning, please see knowledge article EBS: ‘Your Role May Not Have Sufficient Permissions to View/Edit All Sections of This Template’ When Saving Notification Template Changes in Everbridge Suite.
Solution
There is no way to retrieve the missing components. To avoid this situation in the future:
- Instruct users to heed the warning message and not save the template, or
- Configure the system so that this situation does not arise. You can do this by enabling the settings below. These are enabled by default and apply to notifications, incidents and scenario templates.
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