Problem
When saving notification template changes in Everbridge Suite, the following warning message is displayed:
Your role may not have sufficient permissions to view/edit all sections of this Template. If you SAVE this Template, the sections that you do not have permission for (if applicable) will be removed from the Template.
Use Case
A user with role A can edit templates created by users with a different role, say role B. The permissions configured for role A and role B could be different. When a user with role A edits a template created by a user with role B, the above warning message is displayed. The template components that role A does have access to will be displayed to the user but the template components that role A does not have access to (if any) will not be displayed while editing the template and these components will be removed from the template on SAVE.
The difference in permissions could be in areas such as contact scope, publishing options, incident chat, etc.)
Root Cause
This message means one or more components in the template may not be visible to the user updating the template due to insufficient privileges and will be removed if the user continues with saving the changes.
Role-based and template-level permissions can both contribute to this behavior:
If the custom role assigned to the user does not include the required permissions for certain template components (for example, specific contact scopes, incident options, or publishing settings), those hidden components are treated as inaccessible and are removed on save.
If template permissions are configured so that the message body or other sections cannot be edited (for example, via the Permissions panel in the template editor), users may see this warning when attempting to modify a template they are not fully permitted to change.
In some cases, broader role dependencies can prevent updates from saving as expected. If the dependent permission is not enabled, changes that rely on that access may fail to save, which can present as permission-related behavior.
Solution
Do not save the template. If the user continues to Save the template, all components not visible to the user will be deleted.
Before proceeding, administrators should:
Review the user's role and confirm it grants the needed permissions for the template components (for example, contact scope, incident options, publishing, or other features used in the template).
Open the template editor (pencil/edit icon) and, on the left side of the page, review the Permissions section to verify whether the message body and other sections are allowed to be edited by the user's role.
For custom roles in Everbridge CEM, verify that any required dependent permissions (such as View Contact Name and External ID when using contact custom reports) are enabled so that template-related changes can be saved successfully.
If the user still cannot safely edit the template, have an Organization Admin or Account Admin (or the appropriate org-level administrator) adjust the role or template permissions as needed, or perform the edit on behalf of the user.
To prevent a situation where this can occur, see knowledge article EBS: Notification Template Components Are Missing After Saving Template Modifications in Everbridge Suite.
Note: This message will always be displayed when a user tries to edit a template created by another role. It does not mean they do not have access to see all components. It means they may not have access. The components they see in the template depend on what permissions their role gives them versus the permissions of the role that was used to create the template.