EBS: Contact Upload Error Code: 'Value is invalid: Country'

Error

Contact Record Status:

Loaded with error

Error Message:

Value is invalid: Country

Contact Uploads error.png

Contact upload failure error messages may be viewed under Contacts > Uploads> User-added image. Selecting the User-added imageupload results icon next to the desired file opens the Upload Results page, where the error is displayed.

Root Cause

This error means that the country code provided for the contact in the Country column was not in an acceptable format.

Common situations where this may occur include:

  • The upload file contains an invalid value such as "USA" instead of the ISO 3166 two-letter code "US".
  • The value in the Country column does not exactly match a supported full country name as it appears in any Country field within the Everbridge CEM Suite web portal.
  • For API-based uploads, the paths.skipValidation setting is configured as true, which bypasses validation and automatic field conversions. In this case, full country names will not be converted to ISO 3166 two-letter codes and any non-compliant values in paths.countryCode may cause invalid country data in the resulting contact records.

Solution

Everbridge utilizes two methods to specify a contact's country during contact uploads:

  • The two-character alpha code defined by ISO 3166

  • The full country name as it appears in any Country field within the Everbridge CEM Suite web portal

To ensure the contact's country is successfully added to the contact profile, verify that the Country column (or the paths.countryCode field when using the Contacts API) contains a valid value.

The following file would cause the error because "USA" is not a valid two-character alpha code as defined by ISO 3166.

Contact Upload Country Error.png

The following file shows what a corrected upload file would look like. The country code has been corrected to "US". The country name "United States" would also be acceptable.

Contact Upload Country Corrected.png

Correcting existing contacts and user-portal update issues:

  • If users cannot update their email address or phone number in the user portal due to a country-related validation error, check the contact's Country field in the manager portal and update it to either:
    • the ISO 3166 two-letter code (for example, "US"), or
    • the exact full country name as displayed in the portal (for example, "United States").
  • If adjusting the country value in the portal does not resolve the issue, the underlying contact record may need to be corrected (for example, by re-uploading or updating the record so its country is stored in a valid format). Once the contact's country is valid, subsequent updates from the user portal should succeed.

For additional information on acceptable country formats, see EBS: How to Upload Country Names for Contact Records in Everbridge Suite.

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