EBS: ‘This username already exists’ When Creating an Account in the Everbridge Member Portal

Problem

When creating an account in the Everbridge Member Portal, the following error occurs:

This username already exists. Enter a new one or reset your password here.
 
User-added image

Root Cause

This error means another user or contact has already registered with this username. Usernames have to be unique across both the manager and member portals. Therefore if a username is being used by a contact, then a user cannot register with that username, and vice versa. See knowledge article EBS: ‘Username already exists’ Message When Registering an Account in the Everbridge Manager Portal.

NOTES:

  • If a user record is deleted, the username may not be reused.
  • If a contact record is deleted, the username may be reused after 30 days at which time the contact record is removed from the Deleted Contacts tab under Manager Portal > Organization > Contacts > Deleted Contacts.

Solution

Continue with the account creation by entering a unique username.

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