EBS: ‘Username already exists’ Message When Registering an Account in the Everbridge Manager Portal

Problem

When registering an account in the Everbridge Manager Portal, the following error occurs:

Username already exists.

User-added image

Root Cause

This error means another User or Contact has already registered with this username. Usernames have to be unique across both the Manager and Member Portals. Therefore if a username is being used by a Contact, then a User cannot register with that username, and vice versa. See knowledge article EBS: 'This username already exists' When Creating an Account in the Everbridge Member Portal.

Usernames are unique across all Everbridge accounts, meaning if a username has been used in any Everbridge environment previously, it cannot be reused, even if the original account appears to be deleted or no longer active.

NOTES:

  • If a User record is deleted, the username may be reused immediately.

  • If a Contact record is deleted, the username may be reused after 30 days at which time the Contact record is removed from the Deleted Contacts tab under Manager Portal > Organization > Contacts > Deleted Contacts.

Solution

If you encounter this error, try the following options:

  1. Continue with the account registration by entering a different unique username.

  2. If you're trying to use your email address as your username, consider using an alternative username that differs from your email address.

  3. Contact your system administrator to verify you don't already have an existing account.

  4. If you need to use a specific email address that's already associated with another Everbridge organization, try using just the email prefix (the part before the @ symbol) as your username.

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