EBS: When Downloading a Report, Contact, User or Asset List in Everbridge Suite to a CSV File, It Downloads as a TXT File Instead of a CSV File in Everbridge Suite

Problem

When downloading a report, contact, user, or an asset list to a CSV file, it downloads as a .txt file instead of a .csv file, or the downloaded .csv file.

Root Cause

If a report (or a Contact, User, or an Asset list) has downloaded as a text-type file, it indicates that at least one text field begins with one of the following characters:

=
+
-
@
'
"

NOTE: Text fields beginning with - or + that are followed by numbers (for example, +1 818-230-9798) will not result in the file downloading as a text file.

Solution

To change a .txt file to a .csv file, follow the steps below:

  1. Open the text file.

  2. Click File, then Save As.

  3. Add .csv to the end of the file name.

  4. From the Save as type drop-down menu, select All Files.

  5. Click Save.

Saving Text File as CSV

After converting the file to .csv, if the data is not properly displayed when opened in Excel (for example, all data appears in a single column or the formatting is not preserved), use Excel's import feature instead of opening the file directly:

  1. Open Excel and go to the Data tab.

  2. Select From Text/CSV.

  3. Browse to and select your downloaded .csv (or converted .csv) file.

  4. When prompted, select Comma as the delimiter and adjust other options as needed.

  5. Confirm the preview looks correct, then complete the import.

If the new .csv file is still not maintaining the proper formatting, see knowledge article EBS: Downloaded Contact Data And/or Notification Data Is Not Properly Displayed When Imported Into a New Excel File in Everbridge Suite for additional information on how to import files into Excel.

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