Problem:
Contacts with free Email providers such as Hotmail, Yahoo, MS Office 365 and MSN are not receiving Emails sent from Everbridge Suite.
Note: This problem has not been observed with free email providers such as Gmail, iCloud, and MS Outlook.com, or other popular free email service providers other than the above-mentioned providers.
Root Cause:
Periodically, some free email providers have been known to prevent email notifications from reaching Contacts through firewall and filtering systems.
Other reasons for undelivered emails are documented in knowledge base article 000065957 - EBS: Recipients Are Not Receiving Emails From Everbridge.
Solution:
Everbridge works with third-party email providers to the best of our ability to help ensure that your critical communications reach their targets but unfortunately, this is the extent of troubleshooting available to us for systems not under our control (as opposed to our corporate email servers, over which we do have control.)
- For Office 365 issues, see this knowledge base article 000063053: EBS: How to Permit List Email From Everbridge Suite in Microsoft Office 365 Outlook
- For other third-party email systems, Everbridge recommends that Contacts report issues directly to their third-party email vendors.
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