Problem
Delivery method type 'Mobile Push Alert' can not be created or deleted" error encountered when updating contacts via the API.
Root Cause
This error occurs if an API request attempts to create or delete the Mobile Push Alert delivery path, which is not permitted by the application.
Solution
There are three approaches to resolve this issue:
Option 1: Include the Mobile Push Alert field with correct parameters
To accomplish this, include the following json in the "paths" block of the payload, along with any other paths the contact has (email, phone, etc.) Note that this can only be present if the contact has the Everbridge app as a path. An attempt to add the path to a contact without it will result in the same error. For this reason, you need to determine if the path exists prior to creating the update payload if using the PUT method
{
"waitTime": 0,
"pathId": 241901148045325,
"value": "yes",
"skipValidation": false,
"pathEnable": true
}
Note that the Everbridge pathID is 241901148045325 so you should not have to look that up.
Option 2: Use the PATCH endpoint for contacts
We also have a PATCH endpoint which allows for selective editing of contacts without providing the entire contact payload. For example, you can update a single phone number by specifying the appropriate contact path ID.
Option 3: Update the affected contacts manually
If a small number of contacts have the Everbridge app as a path, you may choose to manually edit the details for those contacts.
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