Mobile App Quick Registration Error - "Safari cannot open the page because the address is invalid"

Problem

When attempting to use the Everbridge Mobile App for quick registrations, contacts encounter the error sequence below, which prompts them to download the Everbridge 360 App.

  1. The contact receives the 'Everbridge Mobile App Quick Registration' email from their admin, then clicks the registration link, which opens in their phone browser.
  2. Prompt: 'Confirm: Would you like to launch the Everbridge Mobile Safety app?' > contact selects 'OK'

  3. Receives error: 'Safari cannot open the page because the address is invalid' > contact selects 'OK'

  4. Prompt: 'Download the Everbridge Mobile Safety App' > contact selects 'OK'.
  5. Prompt: 'Open in "App Store" > contact selects 'Open'.

  6. Next, the contact is brought to the app store to download the Everbridge 360 App.

Root Cause

The error occurs because the 'Everbridge Mobile App Quick Registration' will automatically default to sending contacts to the Everbridge 360 App if the Organization has an Organization Code set up for the Everbridge 360 App.  

Solution

If your goal is to use the Everbridge Mobile App, please follow the steps below to resolve the error message and continue using the Everbridge Mobile App. 

  1. Log in to your Manager Portal account and proceed to the Organization level.
  2. Go to Settings > Everbridge Mobile App > Organization Code.
  3. Uncheck the box 'Enable Organization Code', removing the existing Organization code.
  4. Click Save.
  5. Finally, send the contact a new 'Everbridge Mobile App Quick Registration' and request they follow the process to register the Everbridge Mobile App again. 

If the issue persists, contact Everbridge Technical Support for further assistance.

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