EBS: Cannot Update a Field Under a Contact's Static Location in Everbridge Suite

Problem

When editing a Contact, information entered under "Static Location(s)" is not saved. (Contacts + Assets > Contacts > Contact List > {edit Contact} > Static Location(s)).

You enter information in one of the blank fields under Static Location(s), press Save, and see the "Saved Successfully" message, but the information you just added is no longer in the field. The field is blank.

Root Cause

The Contact is associated with an Asset.

Solution

Update the Asset associated with the Contact.

  1.  Log in to the Everbridge Manager Portal and select your Organization
  2. Select Contacts + Assets > Assets > Asset List  
  3. Select the pencil icon next to the Asset
  4. Update the Address fields
  5. Click Save 

 

 

 

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