Problem
When editing a Contact, information entered under Static Location(s) is not saved. (Contacts + Assets > Contacts > Contact List > {edit Contact} > Static Location(s)).
You enter information in one of the blank fields under Static Location(s), press Save, and see the "Saved Successfully" message, but the information you just added is no longer in the field. The field is blank.
Root Cause
The Contact is associated with an Asset, and the Static Location field you are trying to update is controlled by that Asset record (for example, an office or Facility address). When the Contact record is saved or refreshed, the Contact's Static Location is re-synced from the underlying Asset, overwriting your manual change.
Solution
Update the Asset associated with the Contact so the correct address is stored on the Asset and then synchronized to the Contact.
Log in to the Everbridge Manager Portal and select your Organization.
Select Contacts + Assets > Assets > Asset List.
Select the pencil icon next to the Asset associated with the Contact.
Update the address fields (including Country).
Click Save.
After the Asset is updated and saved, the Contact's Static Location will inherit the corrected address information the next time it is synchronized.
Workaround
If you cannot update the Asset directly:
Contact your organization's Everbridge or system administrators and ask them to update the Asset / Facility record with the correct address.
If the Asset is managed by an automated feed, make sure the upstream data source is corrected; otherwise, the next automated upload may overwrite any manual fix to the Asset's address or geometry.