Problem
When saving notification template changes in Everbridge Suite, the following warning message is displayed:
Your role may not have sufficient permissions to view/edit all sections of this Template. If you SAVE this Template, the sections that you do not have permission for (if applicable) will be removed from the Template.
Use Case
A user with role A can edit templates created by users with a different role, say role B. The permissions configured for role A and role B could be different. When a user with role A edits a template created by a user with role B, the above warning message is displayed. The template components that role A does have access to will be displayed to the user but the template components that role A does not have access to (if any) will not be displayed while editing the template and these components will be removed from the template on SAVE.
The difference in permissions could be in areas such as contact scope, publishing options, incident chat, etc.)
Root Cause
This message means one or more components in the template may not be visible to the user updating the template due to insufficient privileges and will be removed if the user continues with saving the changes.
Solution
Do not save the template. If the user continues to Save the template, all components not visible to the user will be deleted.
To prevent a situation where this can occur, see knowledge article EBS: Notification Template Components Are Missing After Saving Template Modifications in Everbridge Suite.
Note: This message will always be displayed when a user tries to edit a template created by another role. It does not mean they do not have access to see all components. It means they 'may' not have access. The components they see in the template depends on what permissions their role gives them vs the permissions of the role that was used to create the template.
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