Problem:
When logged into the Manager Portal as a Group Manager, the Everbridge Universe map takes significantly longer to load than when logged in as an Org Admin.
Root Cause:
The Everbridge Universe tab (and the map shown when selecting contacts via map) loads your contacts differently based on your role. For account or organization admins, a data layer and an image layer is loaded for each contact record type available. Because group managers don't have direct access to all contacts, a data layer and an image layer is loaded for each group available to the user instead.
Solution:
If you find that the map is taking too long to load for group managers, review and clean up your groups to minimize the amount of data that Everbridge needs to load for your group managers.
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