Problem
The Manager Portal page is not loading correctly.
Root Cause
A browser's cache being full can occasionally cause this issue. Other browser-related factors such as outdated browsers or connectivity issues may also affect the proper loading of the Manager Portal.
Solution
As an initial troubleshooting step, clearing a browser's cache is best practice before contacting Everbridge Technical Support. Refer to the documentation linked below for steps to clear the cache for the most popular browsers.
NOTE: Everbridge does not endorse any particular browser for use with Everbridge products.
If clearing the cache doesn't resolve the issue, try these additional troubleshooting steps:
- Ensure you are using a supported and up-to-date web browser
- Check your internet connection
- Restart your browser
- Try accessing the platform from a different browser
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