EBS: Security Pop-up Alert Persists After SSO Certificate Update

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Problem

After updating your Single Sign-On (SSO) certificate as per knowledge article EBS: Everbridge Single Sign-On (SSO) Certificate Update you are still being prompted with a security pop-up alert that indicates the update is still needed.

Root Cause

This issue can occur in the following scenarios:

Scenario 1

When a member portal SSO configuration at the organization level has overwritten the account-level configuration leaving the account-level configuration with no organization information (see below).

  1. Log in to the Everbridge Manager Portal as an Account Administrator
  2. Select Settings > Security > Single Sign-On for Member Portal 
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Scenario 2

When an account-level member portal configuration has been disabled by unchecking the organization within the configuration (see below).

  1. Log in to the Everbridge Manager Portal as an Account Administrator
  2. Select Settings > Security > Single Sign-On for Member Portal 
sso32.jpg

 

Scenario 3

When a disabled organization has an SSO configuration linked to it.
 

Solution

This issue has no impact on the certificate update itself. However, to prevent the security alert window from continuing to pop-up with an update reminder, there are multiple solutions depending on the root cause.

Scenarios 1 and 2

If the root cause is as described in scenarios 1 and 2 above, remove the unused account-level member portal configuration. Since the SSO configuration at the organization level is the one in use (each org SSO configuration is differentiated by API name), removing the unused account-level configuration will not impact the use of SSO.

To remove the account-level member portal configuration:

  1. Log in to the Everbridge Manager Portal as an Account Administrator
  2. Select Settings > Security > Single Sign-On for Member Portal 
  3. Click Remove
  4. Answer Yes in the Confirm pop-up window.
sso33.jpg

 

Scenario 3

If you know the root cause to be that a disabled organization has an SSO configuration linked to it (Scenario 3), or if you are unsure of the root cause and you have tried the solution above, please contact Everbridge Technical Support and refer to this knowledge article.

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