EBS: After Updating Your Single Sign-on (SSO) Certificate, a Security Pop-up Alert Continues to Prompt for an Update

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Problem:

After updating your Single Sign-On (SSO) certificate as per Knowledge Base Article 000059811 - Everbridge Single Sign-On (SSO) Certificate Update User Guide, you are still being prompted with a security pop-up alert that indicates the update is still needed.

Root Cause:

This issue can occur in the following scenarios:

Scenario 1:

When a member portal SSO configuration at the organization level has overwritten the account-level configuration leaving the account-level configuration with no organization information (see below).

Account Level - Member Portal (Account > Settings > Security > Single Sign-On for Member Portal)
 
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Scenario 2:

When an account-level member portal configuration has been disabled by unchecking the organization within the configuration (see below).

Account Level - Member Portal (Account > Settings > Security > Single Sign-On for Member Portal)
 
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Scenario 3:

When a disabled organization has an SSO configuration linked to it.
 

Solution:

This issue has no impact on the certificate update itself. However, to prevent the security alert window from continuing to pop-up with an update reminder, there are multiple solutions depending on the root cause.

Scenarios 1 and 2:

If the root cause is as described in scenarios 1 and 2 above, remove the unused account-level member portal configuration. Since the SSO configuration at the organization level is the one in use (each org SSO configuration is differentiated by API name), removing the unused account-level configuration will not impact the use of SSO.

To remove the account-level member portal configuration:

  1. Log in to the Manager Portal at the Account level.
  2. Select Settings from the top menu bar.
  3. Select Security from the menu on the left.
  4. Select Single Sign-On for Member Portal from the sub-menu.
  5. Click Remove.
  6. Answer Yes in the Confirm pop-up window.
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Scenario 3:

If you are unsure of the root cause and you have tried the solution above, or if you know the root cause to be that a disabled organization has an SSO configuration linked to it (Scenario 3), please contact Everbridge Technical Support and refer to this Knowledge Base Article.


 
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