EBS: iPaaS Error 'Problem getting template for orgId' and Message Status is 'FAIL'

Problem

When sending a request to iPaaS, the Message Status is listed as FAIL, and one or both of the following errors will be listed under the event details of the messsage:error

Problem getting template for orgId

Missing Incident Template for OrgID

For example, after sending a request to iPaaS, review the iPaaS settings page in Everbridge Suite by following the steps below:

  1. Log in to the Everbridge Manager Portal at the organization level.
  2. Select Settings from the top menu bar.
  3. Select Everbridge Open from the drop-down menu.
  4. Select IPaaS from the menu on the left.
  5. Select Settings from the sub-menu.
  6. Review the activity and you may see the Message Status of "FAIL" for your request, as highlighted below.

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  1. Clicking on the Request ID will provide more details on the request and why it failed to send.

 

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When reviewing the Event Detail, the error message, note the following error message is listed:

Problem getting template for orgId

The following additional error may also be listed:

Missing Incident Template for OrgID

Root Cause

The template specified in the iPaaS condition has either been deleted or put into draft mode.

Solution

Determine the status of the template and either set the template to live or create a new template if necessary.

  1. Log in to the Everbridge Manager Portal at the organization level.
  2. Select Incidents from the top menu bar.
  3. Select Templates from the drop-down menu.
  4. Click the pencil icon next to any template to open the URL https://manager.everbridge.net/incidents/template?id=[templateID], where [templateID] is a string of numbers identifying the template.
  5. Copy the template ID from the Event Detail error and paste it in place of [templateID].
  6. Press return and one of two things will happen.
  1. The template information will appear in the browser
  2.  You will see the following error:

 

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If the template is found, use the radio button to change the status to Live and save your changes.

 

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Your iPaaS requests should now work as expected.

However, if you get the error that the template does not exist, you will need to create your template again and assign it to the appropriate iPaaS condition.


 

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