Problem:
When downloading Contacts from the Manager Portal in Everbridge Suite (Contacts > Contact List > Download), External IDs show as exponential numbers in the downloaded CSV file. This is true for both Active and Deleted Contacts. For example, 123456789123456789 shows as 1.23457E+17.
When clicking on the cell contents, the number shows as rounded up. For example, 1.23457E+17 shows as 123456789123456000.
Root Cause:
Microsoft Excel converts numeric values that exceed 15 digits to exponential numeric format.
Solution:
If you know what the External ID should be:
- Open the downloaded file
- Right-click on the target cell
- Click on Format Cells
- On the Number tab select Text
- Click OK
- Type the full External ID into the field
- Optionally choose Ignore Error
In most cases, you will not know what the External ID should be. In these cases, follow the steps below:
- Start MS Excel
- Click File > Open > {name of your downloaded file} (This will open an import wizard box. NOTE: Do NOT open the file directly by clicking on it. If you do, the import wizard box will not open automatically.)
- Choose Delimited
- Next
- Select the Comma delimiter (This selection presents the columns most clearly)
- Next
- Select the column which contains > 15 digits of numbers
- Select Text (Do this after selecting the column so that only the format of this column is modified)
- Select Finish.
Below are some helpful links that explain the above issues and resolution:
https://answers.microsoft.com/en-us/msoffice/forum/msoffice_excel-mso_winother-mso_2010/excel-auto-roundoff-long-numbers-in-the-csv-file/da7d0929-4b2a-45a3-9187-cc4b9211a523
https://docs.microsoft.com/en-us/office/troubleshoot/excel/long-numbers-incorrectly-in-excel
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