EBS: Editing the Sender Caller ID on a Notification or Incident Template Changes the Country Flag Resulting in a ‘Please enter phone in the correct format’ Error in Everbridge Suite

Problem:

When editing the Sender caller ID on a notification or incident template to a different number in the same country, the country listed remains as expected but the country flag changes to another country. This prevents the notification/incident from being sent with the following error message:

Please enter phone in the correct format

In the example below, a United States phone number has been modified and the flag changed to Russia.

Root Cause:

This problem occurs if the new Sender caller ID phone number is entered without specifying the proper country code. When entering a phone number in the Sender caller ID field, the Everbridge platform interprets the first number(s) entered as the country code. This means that if no country code is entered, it will be interpreting the first number(s) of the phone number as the country code. In the above example, the phone number starts with '7' which is the country code for Russia which causes the flag to change to Russia. As another example, if the phone number had started with '44' which is the country code for the United Kingdom, the flag would have changed to the flag of the United Kingdom.

Solution:

Enter the country code first, then the phone number. In the above example, the country code for the United States is '1', so enter '1703' and the rest of the number in the Sender caller ID field.




 
Was this article helpful?
0 out of 0 found this helpful

Article Feedback

Please sign in to leave a comment.