Error
Email ingestion integration fails to trigger an incident when a required variable is not included in the incoming email.
Error Message:
Missing a required Variable
Root Cause
The error indicates that one of the variables is missing in the email sent to the integration and the Incident could not be triggered.
Solution
Review the error details and update the email to include the missing variable, then resend the email to the email ingestion integration.
Follow the steps below to review the error of a failed email ingestion integration:
Required Variable Error
- Log in to the Manager Portal and select your Organization.
- Click on the Settings tab from the top of the page.
- Click the Everbridge Open sub-tab.
- Click on the number for Emails Received next to the desired integration.
- Verify if the email was received and click on the error link.
The error will display which variable is missing from the email received. For more information on variables see knowledge article: EBS: Editing Information Variables Used in Incident Templates in Everbridge Suite.