EBS: Email Ingestion: 'Failed to retrieve template variables. Details: Unauthorized'

2026-05-08 12:36:49 UTC

Error

When reviewing the list of emails received for an email ingestion integration, an email may display a status of "FAILURE" with an error of "Internal Error". Selecting the error opens a pop-up message indicating an authorization issue when retrieving template variables.

Error Code:

Internal Error

Error Message:

Failed to retrieve template variables. Details: Unauthorized

Failed to retrieve template variables error message for email integration

Root Cause

The user who created the integration has been deleted or is disabled.

Solution

If the user has been deleted, a current user can become the Updated By user for the integration, which will resolve the issue.

1. Click the pencil icon to the left of the integration name to open it for editing.
2. Scroll to the bottom of the page and click the Save button. No changes are needed.
3. Verify that the current user's name is now shown in the Updated By column.


If the user who last updated the integration still exists but is disabled, a second option is to enable the user.

1. Go to Access > Users in the Manager Portal.
2. Click on the pencil icon to the left of the user's name to edit.
3. Click the Enable button next to the words, This user account is currently disabled, and confirm that you want to enable the user when prompted

Enable button

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