EBS: Delivery Section Missing From Contact Record That Previously Had a Delivery Method; Unable to Add Delivery Method; Call Result Is ‘Not Attempted - Invalid Path' in Everbridge Suite

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Problem:

  1. When attempting to add a delivery method to a contact, you are unable to add a delivery method because the "Delivery Methods" section of the Contact Record (Contacts > Contact List > {Edit - pencil icon}) is missing:
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  1. When viewing the notification details under Notifications > Active/History > {title} > Delivery Details, the Call Result show a Delivery Method Value indicating the contact has a delivery method defined:
Not Attempted - Invalid Path
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  1. As a result, you are unable to add, edit, remove, or view delivery methods for that contact.

Note: If you see "Not delivered – Contact Path Not Defined" in the delivery details, this indicates that the selected delivery paths for the notification do not match any of the delivery methods configured in the contact's record. You should review both the notification's delivery path settings and the contact's configured delivery methods to resolve the issue.

Root Cause:

Invalid data is stored in the contact record. This can happen with contact records that have old data prior to the validation checks that contact uploads have today.

Workaround:

Delete and add the contact record again. Due to current validation checks in the product this will not happen again.

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