Problem
Connecting to Everbridge via SFTP to upload contacts generates the following error:
server refused our key
Root Cause
The SFTP Key used was not converted correctly or it is corrupted.
Solution
Ensure that the SFTP Key is converted correctly by following the steps in knowledge articles EBS: Configuring SFTP at the Organization Level for Use With Everbridge Suite or EBS: Configuring SFTP at the Account Level for Use With Everbridge Suite under "Authenticating Using a Private Key". This sections explains how to download and/or generate a private key and use PuttyGen to convert the key to a Putty Compatible key.
Additional Troubleshooting Steps
- Verify that you are connecting to the correct SFTP hostname: sftp-aws-us.everbridge.net
- Ensure that the public key you are using matches the one provided by Everbridge
- If the issue persists, try removing any existing public keys and re-add the Everbridge-provided key to your SFTP configuration
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