EBS: Connection to the AWS SFTP Host Name Is Successful but an Error Occurs Setting the Permissions And/or Timestamp

Problem

You can connect to the new modernized Hostname, but when you transfer a file into the SFTP folder, you receive an error or warning related to a permissions issue. The examples given below are errors shown in the FTP client WinSCP. Your error may differ depending on the FTP Client and associated scripting used. 
 

Upload of file '<name of file>' was successful, but error occurred while setting the permissions and/or timestamp.

If the problem persists, turn off setting permissions or preserving teimstamp. Alternatively you can turn on 'Ignore permission errors' option.


The server does not support the operation.
Error code: 8
Error message from server (US-ASCII): SETSTAT unsupported

 

User-added image


Permission denied.
Error code: 3
Error message from server (US-ASCII): Access denied

User-added image

Root Cause

This problem is occurring due to the recent migration from the legacy SFTP service to the new modernized SFTP service. Certain actions are not allowed on the new modernized SFTP service.  Please note that these errors occur after the file is transferred successfully. Log into the Everbridge Manager Portal to verify that your file was uploaded. This will confirm if the solution and/or workarounds should solve the issue. 

Solution

To remove this warning/error message from displaying in WinSCP, please follow the instructions below. The steps may be different for your specific FTP Client. 

  1. Open WinSCP.
  2. Under Options, Select Preferences.  
Preferences                                                  
  1. If applicable, next to Other general options, select Preferences.
  2. If Step 3 is not applicable, select Transfer.
  3. Select the Edit button.    
Transfer/Edit

                                

  1. Under Common Options, uncheck Preserve timestamp.
Timestamp/OK
  1. Select OK.                                                                        
  2. Select OK again.

 

Workarounds:

If you are still getting the pop-up after making these changes, there are two other workarounds.

Workaround 1

  1. Disable or increase the size of the Transfer > Endurance setting.
Transfer/Endurance setting
  1. Select OK.

Workaround 2

  1. Add .csv or .zip file format to the default Transfer mode settings under Automatic.    
Transfer file types          
  1. Select OK.

For more information related to modernized SFTP, see knowledge article EBS: Upgrading Your Secure File Transfer Protocol (SFTP) Service to the Amazon Web Services (AWS) Hosted SFTP Service in Everbridge Suite.

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