Problem:
When uploading legacy Safety Connection buildings, the geocoding process generates the error:
LOC_GEO_CODING_ERROR: null: null
Root Cause:
An address cannot be geolocated if the Longitude: Latitude values have not been defined either in the CSV file or the Point Address Data entry when set to use My Point Address Info. Instead, the Longitude: Latitude values display null: null and prevents the record from loading.
Solution:
- Find the Longitude: Latitude values of the building's address using a mapping site such as Bing Maps. Then, enter the Longitude/Latitude values into their associated column entries for that building in the CSV upload file.
- Create an entry for the address under the Published sub-tab from the Point Address Data menu bar located under Settings > Organization > Map > Point Address Data > Published. Click + Add Address, then enter the associated information and click Save. The file upload will not require the Latitude: Longitude values because the pointed address will be recognized.
- Set the Geo-Coding Application under Point Address Data to Everbridge Service or My Point Address Info And Everbridge Service to enable auto-geocoding so that the Latitude: Longitude values are not required for Buildings uploads.
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