EBS: Groups Are Removed From Contacts Whenever a CSV File Is Uploaded to Everbridge Suite

Problem

Groups are removed from contacts whenever a CSV file is uploaded to Everbridge Suite.

Root Cause

Specific syntax is required when uploading contacts so that contacts are not accidentally removed from groups. One cause of this problem is when there are blank values under the Groups header column in the upload file. Uploading a file with any fields under the Groups header having a blank value will "blank out" the data for that field for that contact. For example, if the Groups header in an upload file has all blank values, then all contacts affected by the upload will be removed from any groups.

Another cause of this problem is when the asterisk ( * ) character is not properly used in each group cell to preserve existing group associations.

Solution

The best solution to prevent groups from being removed is to exclude the "Groups" column from the upload file completely. When you don't include the "Groups" column, the system will not make any changes to existing group associations, allowing them to remain intact after each upload.

If you need to manage groups in the upload file, consider the following approaches:

  1. Perform two separate uploads: For example, one for 'Update' and another for 'Delete'. This will ensure that existing groups are not removed from the contacts during the update process.
  2. When uploading contacts, select the appropriate action to manage your contact data effectively.

If you must include the "Groups" column in your upload file, see the following references for proper syntax and usage:

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See knowledge article EBS: Adding Contacts to Groups via an Upload File in Everbridge Suite for information on how to preserve existing group associations when uploading contacts and how to safely add/remove contacts to/from groups without deleting existing group associations.

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