Problem
Dispatchers cannot see Notifications that were sent by other Users in Everbridge Suite.
Root Cause
Users with the Dispatcher Role will only be able to access the Notifications its specific Role has sent. For instance, a Dispatcher Role cannot stop, rebroadcast, or follow up a Notification if it has been sent by an Account or Organization Administrator, or even a different Dispatcher Role.
Solution
There are two ways to address this issue:
Give Dispatchers multiple Roles to access Notifications sent by other Dispatchers.
Create a Custom User Role with the 'Access to all communication resources' permission. This will grant the dispatcher role the ability to see all Notifications, including those sent by Administrative Users. To set this up:
Go to the 'Resources' tab when creating a new custom role
Select the 'Access to all communication resources' option
Article Feedback
While we can’t respond to you directly, we’d love to know how we can improve the article.
Please sign in to leave a comment.