Problem
The following error is generated when hovering over Edit Layers or clicking on Staffing:
Contact not available - either you do not have permission or they have been deleted.
Root Cause
This error is displayed when:
The contact referenced by the layer or staffing record has been deleted and is no longer available in the active contact list, or
Your user profile does not have the necessary permissions to view deleted or restricted contacts.
In some cases, deleted contacts are intentionally moved to a restricted area for security and data management reasons, especially when the contact record may contain sensitive information. In those situations, the issue is related to access authorization and configuration rather than a technical malfunction.
Solution
If the contact was deleted, they can be restored:
Locate the deleted contact by clicking on the Contacts tab.
Click on the Scheduling sub-tab.
Click on the Admin view.
Click on Audit Logs on the left-hand side of the page.
Select the desired calendar in the drop-down list next to Pick Calendar.
Select a date range for when the contact would have existed.
Once the name of the contact is found, restore the contact. See knowledge article EBS: How to Restore Deleted Contacts in Everbridge Suite.
If the error is permission-related (for example, you see a You are not Authorized message when attempting to access related pages such as the Contact Us tab), contact Everbridge Technical Support or your organization administrator. Your user profile may need to be updated to grant authorization to view the relevant contacts or pages.