EBS: Contact Upload Error Code: 'Value is Invalid: Postal Code'

Error

Contact Record Status: 

Loaded with error

Error Message:

Value is invalid: Postal Code

Contact Uploads error.png

Contact upload failure error messages may be viewed under Contacts > Uploads> User-added image.  Selecting the User-added imageupload results icon next to the desired file opens the Upload Results page, where the error is displayed.

Root Cause

This error occurs when a ZIP code is missing one or more required digits. The issue commonly occurs with ZIP codes that begin with the digit "0" and have the leading zero removed by Microsoft Excel.

Spreadsheet editors such as Microsoft Excel may automatically format numerical values and remove leading zeros. When this occurs, postal codes that begin with zero may upload without the leading digit or fail validation during the upload process.

The end of the error message identifies the ZIP code entry in the CSV upload file that contains missing digits.

When preparing a CSV file using a simple text editor to ensure the leading zeros in the Postal Code column are preserved automatically and no additional formatting is required.

Solution

Verify that ZIP codes in the CSV upload file contain the correct number of digits. If leading zeros were removed by Excel, apply the following formatting to the Postal Code column before saving the CSV file:

  1. Select the Postal Code column by choosing the column header above the first "Postal Code" cell.
  2. Right-click any cell within the selected column and choose Format Cells.
  3. From the Category list, select Special.
  4. From the Type list, select Zip Code.
  5. Choose OK to apply the formatting.
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