EBS: Additional Information Fields on the Member Portal Do Not Display Correctly in Everbridge Suite

Problem:

When contacts try to register via the member portal URL, the single selection Additional Information fields in the registration process are not working as expected. Specifically, contacts can only choose a specific variable value for each field.

The Additional Information fields are supposed to allow contacts to provide more information about themselves, such as their language selection, job title, or related skills. However, when contacts try to choose a value for one of these fields, they can only choose a specific variable value. For example, if the field is for the contact's job title, the only possible value is "CEO." This prevents contacts from providing accurate and complete information about themselves, which could impact their ability to use the member portal.

The screenshot below shows an example of this issue. The Additional Information value "No" is floating in the middle of the window rather than being part of the drop-down list. In this example, the Additional Information field "New Info" has been configured with the values "Yes" or "No." However, the screenshot only shows the value "No", and "Yes" cannot be selected.

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Root Cause:

In December 2022, Everbridge modified the URL format for the member portal. If the outdated URL is shared with contacts for registration purposes, it will disrupt the proper display of the additional information section during registration.

Solution:

To ensure an issue-free registration process, it is necessary to use the new URL format. The new URL may be found in the Member Portal section of the Organization Settings. 
Be aware that links could still be in the old format on your website or social media pages. Confirm that the sign-up URL ends with "/new" rather than "/signup." Example below:

 
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