Mobile: Some Contacts Cannot See the Safety Buttons in the Everbridge Mobile Application (EMA)

Problem:

Some contacts cannot see the Safety Connection shield icon or cannot see specific buttons in the Everbridge Mobile Application (EMA).

Root Cause:

Either the Safety Connection buttons are disabled in the organization settings or a button is configured with visibility that excludes some contacts.

Solution:

Enable the Safety buttons by following the steps below:

  1. Log in to the Manager Portal and select the desired organization from the upper right-hand corner.
  2. Click on the Settings tab.
  3. Click on the Everbridge Mobile App sub-tab.
  4. Click on Application Options.
  5. Click Safety and select the check box for Enable safety features in Everbridge Mobile App.
  6. Under MANAGE SAFETY BUTTONS, enable the desired safety buttons by selecting the corresponding check boxes.
  7. Click Save.

If Safety buttons are enabled, configure their visibility by following the steps below:

  1. Log in to the Manager Portal and select the desired organization from the upper right-hand corner.
  2. Click on the Settings tab.
  3. Click on the Everbridge Mobile App sub-tab.
  4. Click on Application Options.
  5. Click Safety.
  6. Click on the desired Button Name.
  7. Select the desired radio button for Who Can See This Button?
    • All contacts - enables the Safety Connection buttons for all contacts.
    • Selected groups - enables the Safety Connection buttons for specified contact groups.
    • Selected rules - enables the Safety Connection buttons for specified contact rules.
  8. Click Save.
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