EBS: Troubleshooting "@everbridge.net" in the Email "From" Field in Everbridge Suite

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Problem:

You see @everbridge.net in the email From field when you expect to see your own organization's domain. 

Root Cause

This is likely due to your account or organization having a custom email address enabled but not set up properly. The Custom From Email Address is an Everbridge Suite (EBS) premium feature that provides Everbridge customers the ability to customize the "From" address for outgoing email Notifications. It must be set at the Account and/or Organization level and affects all notification emails going out of that Account and/or Organization.

Solution

Due to the sensitive nature of the From address configuration, you must contact Everbridge technical support to have this field updated. Please contact technical support to have your Custom From Email Address set up. 

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