Problem
Contacts receive Notifications where polling options are displayed as links in SMS messages from Everbridge Suite.
Root Cause
A polling option may appear as a link in a text message because the mobile device treats the content of the option as a URL.
In the image below, the mobile device has interpreted the second through fourth options as URLs because the content of the options forms valid web addresses.
In addition, URL checking or scanning software on the recipient side (for example, on a mobile device or email/SMS gateway) may automatically open any links that appear in the notification. Everbridge systems monitor when confirmation links are activated; if a URL checker opens a confirmation link, that activation is recorded as a response, which can cause contacts' polling responses to be recorded incorrectly.
Solution
To prevent a polling option, such as "no", from becoming a URL on mobile devices, insert a hyphen (-) before the "no", as shown below.
NOTE: Inserting spaces before the polling option will not prevent the options from becoming URLs.
To reduce the chance of incorrect responses being recorded due to automatic URL scanning, administrators should work with their internal IT teams to identify and configure any URL-checking or scanning tools on recipients' devices or gateways so that they do not automatically activate Everbridge confirmation links.