EBS: Contact Upload Error Code: 'Required Column Not Found'

Error

Error Code:

Required Column Not Found

Error Message:

  • External ID
  • Record Type
  • First Name
  • Last Name

NOTE: Contact Upload file failure error messages may be viewed under Contacts > Uploads > User-added image. Clicking on the User-added image icon next to the desired upload file brings you to the Upload Results page where the error is displayed.

Root Cause

This error can occur for a few different reasons that will be explained with examples. Check the Error Message column under Header Errors for the column/header affected.

  • Required Column Missing - CSV upload file is missing one or more required columns. The column could also be present but the header is missing or misspelled. 
  • Encrypted File - If an encrypted file is uploaded, but encryption is turned off for the Organization it will cause a missing column error for all four required columns. 
  • Delimiter Setting- If your file has an error for all four required columns, AND your file was uploaded via SFTP, your Organization delimiter setting might not match your file.

Solution

Please see the solutions below for each of the separate root causes of the error. 

Root Cause - Required Column Missing

In this example, the error is due to a missing or misspelled required header. The required headers/columns are External ID, First Name, Last Name, and Record Type.
Contact Upload Missing External ID.png

The following file would cause the above error. 

Contact Upload Sheet Mispelled External ID Column.png

Note that "Externall ID" is misspelled in the column header. Column headers need to exactly match the format provided in the Upload template unless the Contact Upload Mapping feature is being used. The solution, in this case, would be to download the Upload template, observe the column header for External ID and change the column heading to match that format. In this case External ID. For more information see Knowledge Base Article 000002683 - How to Download a CSV Template that can be used for Uploading Contacts into Everbridge CEM Suite.

Root Cause - Encrypted File

If your CSV upload file has a required column error for all four required columns (External ID, First Name, Last Name, and Record Type) and has an extension of .gpg or .pgp, then your file is encrypted but encryption is not turned on. Please notice in the screenshot below the 4 required column errors and the .gpg extension of the file. 

Contact Upload Encrypted File.png
There are two options for fixing this issue. 
  1. If you want to continue without using file encryption, please make sure your CSV upload file is a standard unencrypted CSV file and try again.
  2. If you want to enable file encryption, please follow these steps and see the screenshot below:
    1. Navigate to Settings > Contacts/Assets > Upload Options > Secure FTP
    2. Change the Encryption Status option to On in the File Encryption section. 
    3. Choose the Download button to download a copy of your Encryption Key
      • NOTE: Everbridge cannot troubleshoot encryption issues with your third-party encryption tool.
    4. You can also choose the option to Generate a New Key if desired, which will render any upload files using the previous key invalid. Use with caution!
      File Encryption Options.png

Root Cause - Delimiter Setting

If your CSV upload file has a required column error for all four required columns (External ID, First Name, Last Name, and Record Type)  and your file was uploaded via SFTP, your Organization delimiter setting might not match your file. Please notice in the screenshot below the 4 required column errors and the sender of the file is SFTP.

Contact Upload Delimiter.png
To check what delimiter your CSV upload file is using, open your file in a basic text editor, such as notepad, and observe the punctuation that separates the values. It should be a comma (,) or a semicolon (;). The example CSV file below that has been opened in Notepad is using the comma delimiter. 
Contact Upload Delimter View.png
Once you have determined the delimiter that your CSV upload file is using, please ensure that your Organization's delimiter setting matches what is being used in the file. The organization delimiter setting can be found under Settings > Organization > Regional Settings.
CSV Delimter Options.png
NOTE: Delimiter settings only apply to files uploaded via SFTP.



 

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