Error
Error Code:
Error Message:
- External ID
- Record Type
- First Name
- Last Name
Contact upload failure error messages may be viewed under Contacts > Uploads> . Selecting the
upload results icon next to the desired file opens the Upload Results page, where the error is displayed.
Root Cause
This error can occur for several reasons. Review the Error Message column under Header Errors to identify the affected column or header.
- Required Column Missing - The CSV upload file is missing one or more required columns. The column may also exist but the header may be missing or misspelled.
- Encrypted File - If an encrypted file is uploaded while encryption is disabled for the Organization, a missing column error may appear for all four required columns.
- Delimiter Setting- If the file displays an error for all four required columns and the file was uploaded via SFTP, the Organization delimiter setting may not match the delimiter used in the file.
Solution
The solutions below correspond to the separate root causes of the error.
Required Column Missing
In this example, the error occurs due to a missing or misspelled required header. The required headers/columns are External ID, First Name, Last Name, and Record Type.
The following file would cause the above error.
In this example, 'Externall ID' is misspelled in the column header. Column headers must exactly match the format provided in the upload template unless the Contact Upload Mapping feature is used.
To resolve the issue, download the official upload template, review the header format for External ID, and update the column name in the file to match the template exactly.
For additional information, see the knowledge article How to Download a CSV Template that can be used for Uploading Contacts into Everbridge CEM Suite.
Encrypted File
If a CSV upload file displays a required column error for all four required columns (External ID, First Name, Last Name, and Record Type) and has an extension of .gpg or .pgp, the file is encrypted while encryption is disabled.
There are two options for fixing this issue.
- If file encryption is not required, ensure that the upload file is saved as a standard, unencrypted CSV file, and then reattempt the upload.
-
If file encryption is required, complete the following steps:
Navigate to Settings > Contacts/Assets > Upload Options > Secure FTP.
In the File Encryption section, set Encryption Status to "On".
-
Choose Download to obtain a copy of the Encryption Key.
- NOTE: Everbridge cannot troubleshoot issues related to third-party encryption tools.
- The Generate a New Key option may also be selected if needed. Generating a new key will invalidate any upload files encrypted with the previous key. This action should be performed with caution.
Delimiter Setting
If a CSV upload file returns required column errors for all four required columns (External ID, First Name, Last Name, and Record Type) and the file was uploaded via SFTP, the Organization delimiter setting may not match the delimiter used in the file.
To determine which delimiter the file is using, open the CSV file in a basic text editor, such as Notepad, and review the character separating the values. The delimiter will typically be either a comma (,) or a semicolon (;).
After identifying the delimiter used in the file, verify that the Organization delimiter setting matches. The organization delimiter setting can be found under Settings > Organization > Regional Settings.