CC: ‘User locked out’ and ‘The specified user account is locked out’ Errors When Attempting to Log in to Everbridge Control Center

Problem

A user is encountering the following errors when logging into Everbridge Control Center:
 

User locked out
The specified user account is locked out.
Please try again or contact your administrator.

 
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Root Cause

The user has attempted to log in to Control Center three or more times with the incorrect password. Once three incorrect attempts have been made, the account is locked.

Solution

To unlock a locked account in the database, please follow these steps. All queries must be run against the Pacific database using SQL Management Studio. 

  1. Find the user ID from the Ipsc.[User] table using the query:
Select [ID], [Label], [Description], [isLockedOut] From [Pacific].[Ipsc].[User]
  1. Copy the value from the ID column. In the above example, the ID of the user whose account is locked out is'27A23AC5-326B-ED11-ABC6-747827CB57AD'
  2. Unlock the account by executing the following query. (Change ID and UserID in the two queries to use the ID you copied in step 2.)
Update [Pacific].[Ipsc].[User] Set isLockedOut = 0 Where ID = '27A23AC5-326B-ED11-ABC6-747827CB57AD'

Delete From [Pacific].[Ipsc].UserLogonHistory Where UserID = '27A23AC5-326B-ED11-ABC6-747827CB57AD'
 
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