NC4: Risk Center - System Requirements - Administration and Configuration

As a browser-based application, NC4 Risk Center has few requirements for normal operation and performance.

Software Requirements

  • Recommend Microsoft Excel, Flash and PDF capabilities
  • NC4 Risk Center Release 7.6 operates with the following browsers:
    • Chrome 45
    • Firefox 41
    • Internet Explorer 10
    • Internet Explorer 11
    • Safari 8.0.3 on Mac OS X 10.10 “Yosemite”
  • ActivPoint officially supported platforms include:
    • iOS 8
    • iOS 9
    • Android 4 and above

Installation

There are no prerequisites for installing NC4 Risk Center. However, system set-up and configuration must be completed using an Administrative User ID.

Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Article is closed for comments.